Actualizar a Thunar 1.6.3 en CrunchBang 11 Waldorf desde el repo XFCE de Mepis

Los fines de semana es lo que tienen, cuando te pilla ese momento sentimental te da por instalar aquellas distros que sabes que son buenas y te dejaron un buen recuerdo. En mi caso, he vuelto a instalar CrunchBang 11 Waldorf en mi viejo portátil Packard Bell.

La cabra siempre tira al monte y los calvos a Debian (o basadas)

cb-1

Como todos sabemos, CrunchBang 11 Waldorf se basa en la actual Debian estable, osease, Wheezy, la cual anda aún por el Xfce 4.8, con el navegador de archivos Thunar en la versión 1.2.3, algo tosco y carente de las funciones del más moderno Thunar 1.6.3.

Como en esta vida hay muy pocas cosas imposibles, aunque haberlas hailas, el actualizar el Thunar de CrunchBang 11 de la versión 1.2.3 a la última versión estable 1.6.3 es posible gracias al repositorio XFCE de MEPIS, otra gran distro Debian Based.

MEPIS cuenta en sus repositorios con Xfce 4.10 por lo cual tiene el Thunar actualizado.

Los pasos a seguir estan exentos de dificultad, pero antes es necesario saber las consabidas advertencias.

Esto no es obligatorio, en ningún caso me hago responsable de cualquier fallo que pueda suceder si algo sale mal, que me funcione a mi no significa que a ti también pueda hacerlo. La responsabilidad de aplicar el tutto corre a cargo del usuario.

Después de eximirme de cualquier responsabilidad os comento. En mi caso no ha habido ningún fallo, he seguido el tutorial del foro de CrunchBag con alguna leve variación. Tengo activos los repositorios deb-multimedia y wheezy-backports.

Manos a la obra 😉

Accedemos a nuestro sources.lists:

gksu geany /etc/apt/sources.list

Agregamos el repositorio de Mepis y guardamos cambios.

## Mepis Xfce
deb http://main.mepis-deb.org/mepiscr/xfce xfce-4.10 main

Nos vamos a nuestro /etc/apt/preferences:

gksu geany /etc/apt/preferences

Y lo dejamos tal que así sustituyendo lo que haya:

Package: *
Pin: release a=waldorf
Pin-Priority: 990

Package: *
Pin: release n=xfce-4.10
Pin-Priority: 200

Agregamos la key del repo de Mepis:

sudo apt-key adv --keyserver keys.gnupg.net --recv-keys 14E225A0

Actualizamos la información de los repositorios:

sudo apt-get update

Y actualizamos desde este nuevo repositorio:

sudo apt-get -t mx upgrade

NOTA: En el tutto original han usado aptitude, yo he usado apt-get, me fío más de el. El paso anterior me ha actualizado algunas librerías de Xfce que lleva CrunchBang pero no me ha actualizado Thunar, paquetes que me ha retenido en este primer pase.

act-1

En el tutto comentan que no se haga un full-upgrade pues MX (el repo) incluye una versión mucho más nueva de VLC. Puede que eso genere conflictos, en mi caso no ha sido así. Como dije antes no he usado aptitude sino apt-get que trabaja algo distinto, no se me ha actualizado VLC.

Así que para actualizar a Thunar 1.6.3 usando apt-get he necesitado hacer un dist-upgrade al repo.

sudo apt-get -t mx dist-upgrade

Actualizado sin problemas tanto Thunar como sus herramientas y sin tocar paquetes externos que creen conflictos.

act-2

Después de esto solo debemos reiniciar sesión, reiniciar CB, o reiniciar Thunar (thunar -q) para ver los resultados 😉

cb-2

Como extra os dejo mis repositorios en CrunchBang 11 Waldorf a día de hoy.

## CRUNCHBANG
## Compatible with Debian Wheezy, but use at your own risk.
deb http://packages.crunchbang.org/waldorf waldorf main
#deb-src http://packages.crunchbang.org/waldorf waldorf main

## DEBIAN OFICIAL REPO FRANCIA
deb http://ftp.fr.debian.org/debian/ wheezy main contrib non-free
#deb-src http://ftp.fr.debian.org/debian/ wheezy main contrib non-free
 
## DEBIAN SECURITY
deb http://security.debian.org/ wheezy/updates main contrib non-free
#deb-src http://security.debian.org/ wheezy/updates main contrib non-free
 
## DEBIAN BACKPORTS REPO FRANCIA
deb http://ftp.fr.debian.org/debian/ wheezy-backports main contrib non-free
#deb-src http://ftp.fr.debian.org/debian/ wheezy-backports main contrib non-free
 
## Multimedia
## Instalar key # apt-get install deb-multimedia-keyring
deb http://www.deb-multimedia.org wheezy main non-free

## MEPIS
## Instalar Key
## sudo apt-key adv --keyserver keys.gnupg.net --recv-keys 14E225A0
deb http://main.mepis-deb.org/mepiscr/xfce xfce-4.10 main

## Plank Debian Wheezy
deb http://people.ubuntu.com/~ricotz/debian-plank wheezy main

Extra: Firefox 29 Australis luciendo hermoso en CB 11 🙂

cb-firefox29

Que no te lo cuenten…. Vive Linux 🙂

9 comentarios en “Actualizar a Thunar 1.6.3 en CrunchBang 11 Waldorf desde el repo XFCE de Mepis

  1. Xfce 4.8?? wow eso es prehistoria jaja, hasta la 4.10 me parece viejisima y eso que es la última versión.
    Hablando de Xfce…. los muchachos andan un poquitin retrasados con el lanzamiento de la 4.12 jeje, va a pasar a ser un mito linuxero esa versión jaja.

    Por cierto muy hermosa te ha quedado #!, Yo ahora estoy esperando a Xfce 4.12 y a LXQt, la que salga primero va directo a mi Arch.

    Me gusta

  2. arangoiti, comprueba en /etc/fstab que no tienes ninguna linea que haga referencia a USB, una parecida a esta:
    /dev/sdb1 /media/usb0 auto rw,user,noauto 0 0
    Si te aparece, bórrala o coméntala con un # al principio de la misma. Reinicia el sistema y ya deberías poder montar los dispositivos usb.

    Me gusta

  3. Buenos días Yoyo,
    gracias por el blog que me está ayudando mucho en mi primera prueba con Cruncchbang, que es el sistema mas rápido y fluido que he probado en mi vida, y eso que venía de Xubuntu 14.04, que va muy bien también.
    el tema es que echaba de menos el thunar 1.6.3 por lo que he seguido las instrucciones de este post. Ya lo tengo instalado pero hay un efecto secundario indeseable: se ha desisntalado el VLC y no sé cómo volver a instalarlo.
    Cuando hago ‘sudo apt-get install vlc’, esto es lo que me dice el sistema:

    “No se pudieron instalar algunos paquetes. Esto puede significar que
    usted pidió una situación imposible o, si está usando la distribución
    inestable, que algunos paquetes necesarios no han sido creados o han
    sido movidos fuera de Incoming.
    La siguiente información puede ayudar a resolver la situación:

    Los siguientes paquetes tienen dependencias incumplidas:
    vlc : Depende: vlc-nox (= 2.0.3-5) pero no va a instalarse
    Depende: libvlccore5 (>= 2.0.0) pero no va a instalarse
    Recomienda: vlc-plugin-notify (= 2.0.3-5) pero no va a instalarse
    Recomienda: vlc-plugin-pulse (= 2.0.3-5) pero no va a instalarse
    E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.”

    ¿Cómo puedo arreglar esto?

    Gracias
    Casconet

    Me gusta

    • Prueba a #comentar (deshabilitar) el repo de Mepis, luego refrescas repos y pruebas de nuevo.

      Por cierto ¿tienes el repo deb-multimedia?

      No obstante, te aconsejo que repases el hilo original del foro de CrunchBang de donde yo me basé para hacer el tutto, ahí mientan lo del VLC.

      Me gusta

  4. Gracias Yoyo,
    tu comentario me ha dado una buena pista, que me ha permitido solucionarlo:
    – he deshabilitado los repos de mepis y multimedia
    – Desde Synaptic he desisntalado todo lo que hacía referencia a vlc
    – Desde Synaptic ya he instalado sin problemas el vlc
    Saludos

    Me gusta

Deja un comentario

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s