Los drivers nvidia-legacy [nvidia-304xx] ya disponibles en los repositorios de KaOS

Buena noticia para los poseedores de tarjetas gráficas Nvidia antiguas solo compatibles con los llamados nvidia-legacy (nvidia-304xx)

Dese este momento se incorporan a los repositorios de KaOS estos drivers de Nvidia, así que si tienes una vieja gráfica Nvidia de las que solo llegan a los drivers non-free 304xx, ya no tienes excusa para probar KaOS en caso de que no te molen los drivers libres nouveau 😉

Después de un pequeño debate en el foro de KaOS, donde se pedía la opinión de los usuarios respecto a este tema, se ha optado por incorporar dichos drivers a los repositorios. Drivers compatibles con el kernel estable (linux) y con el kernel de largo soporte (linux-lts)

Estos drivers se incorporarían como opción en la siguiente ISO de KaOS, de momento están en el repositorios [build], y como siempre, pasados unos días sin que hayan reporte de errores se pasarán al repositorios estable y estarán disponibles para todos los usuarios.

legacy

Si te encuentras en el caso de tener una gráfica Nvidia antigua solo compatible con los drivers 304xx y deseas probarlos la instalación es bien sencilla, solo hay que seguir el procedimiento de cambiar de los drivers libres nouveau a los no libres nvidia 304xx siguiendo las instrucciones del foro de KaOS.

Hay que tener en cuenta que estos nuevos drivers se llaman nvidia-304xx y nvidia-304xx-lts para el kernel linux y linux-lts respectivamente.

En el caso de querer usarlos en el kernel estable linux.

Nos aseguramos de estar a la última.

sudo pacman -Syu

A continuación desinstalamos libgl, que es necesario para muchas aplicaciones, por lo tanto deberemos usar usar -Rdd para evitar la comprobación de dependencias.

sudo pacman -Rdd libgl

Desinstalamos el paquete nouveau:

sudo pacman -R xf86-video-nouveau

Instalamos el paquete no-libre nvidia-304xx y sus (opcional) settings:

sudo pacman -S nvidia-304xx nvidia-304xx-settings

Esto también instalará automáticamente nvidia-304xx-utils, que tiene su propia versión de libgl incluida.

En el caso de que estemos usando el Kernel LTS debemos instalar las versión lts de los 304xx.

sudo pacman -S nvidia-304xx-lts nvidia-304xx-settings

Reiniciar y disfrutar de los nuevos drivers 😉

En mi caso me viene perfecto para mi vieja Laptop con una Nvidia Geforce GO 7300 solo compatible con los drivers 304xx. Con estos me va bien pero con los nouveau se calienta en exceso la gráfica y no baja de revoluciones el disipador.

Espero que con esto nuestro amigo de El Gato con Linux esté un poco más contento.

En cuanto tenga un poco de tiempo lo pondré en práctica en mi viejo laptop y lo mostraré en un artículo. A ver si puede ser antes o durante el finde 😛

Enjoy 😉

9 comentarios en “Los drivers nvidia-legacy [nvidia-304xx] ya disponibles en los repositorios de KaOS

  1. Gracias Yoyo. Ya no quedan excusas para usar esta maravillosa distro (salvo que tengo que levantar una virtual para usar Sype en el trabajo).

    Por ahora voy bien con los noveau en mi laptop híbirida (Intel HD 4000 + GFORCE 740M). El nuevo kernel, como menciona Demm en el foro, debe apagar la Nvidia él mismo y no he tenido necesidad de instalar bumblebee/bbswitch como en otras distros.

    Solo me queda revisar la configuración de Xorg por algunos “artifacts” aleatorios en algunas decoraciones y el repintado de ventana (por ej cuando la muevo se nota el repintado o bordes cortados que con mi hardware no debería pasar)

    Saludos!

    Me gusta

  2. yoyo, asi como muchos dicen “por fin”,, yo y otros cuantos decimos,, “tarde, ya pase”,, tengo una GF7300GT , y estos drivers eran los ke necesitaba,,, probe KaOS y me encanto, pero se notaba la falta de potencia en graficos, y me decidi a instalarme ARCH, que ya tenia soporte de estos drivers, lo bueno, es ke ahora mucha gente con sus graficas de serie GF5xxxx GF6xxx y 7xxxx van a poder aprovechar al maximo su hardware en KaOS.

    Gracias por este estupendo Blog, que paso a visitar semanalmente, porke me quede encantado de tus aportes, mientras probe KaOS.

    Me gusta

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s